SyntaxError: JSON.parse: unexpected OPENERP 7….. SOLVED WKHTMLTOPDF corrupto!!!


SyntaxError: JSON.parse: unexpected end of data at line 2 column 1 of the JSON data

Este bendito error que ya me he encontrado varias veces y varias veces he resuelto, solo que esta vez me encontré con uno de mis colegas y su nueva instalación de openerp7 en su ubuntu y bueno no daba con el problema yo mismo había corrido un par de informes en esa maquina y el problema es un apt-get install wkhtmltopdf en el ubuntu y parece que este archivo de los repos de ubuntu no funciona con openerp por lo que nos toca instalar a mano 😀

 

aqui dejo los pasos muy sencillos!

0- para mayor comodidad creen un directorio he ingresen

# mkdir /opt/wkhtmltopdf

# cd /opt/wkhtmltopdf

1 Descargamos el archivo, si seque hay una versión mas reciente pero este es el que siempre he instalado!

# wget http://wkhtmltopdf.googlecode.com/files/wkhtmltopdf-0.11.0_rc1-static-i386.tar.bz2

2 descomprimimos el archivo descargado

bunzip2 wkhtmltopdf-0.11.0_rc1-static-i386.tar.bz2

# tar -xvf wkhtmltopdf-0.11.0_rc1-static-i386.tar

 

3 movemos el archivo a los binarios del sistema :D, en caso de haber instalado el paquete nativo lo sobrescribimos

mv wkhtmltopdf-i386 /usr/bin/wkhtmltopdf

 

y listo todo funcionando :D… espero sea de ayuda…. y como a la gente de odoo le gusta borrar sus cosas de los blogs voy a ver si añado una wiki o algo parecido al blog

 

Muchas veces me siento a escribir una entrada y al final decido no hacerla ya que  aveces pienso en hacer del blog mas técnico(cuando estoy trabajando a full) y otras pienso en hacer el blog mas jovial a la final no me decidí y seguiré escribiendo como quiera 😀

 

Anuncios

3 pensamientos en “SyntaxError: JSON.parse: unexpected OPENERP 7….. SOLVED WKHTMLTOPDF corrupto!!!

    • Disculpa hermano… no recuerdo muy bien lo he resuelto asi como dije aqui pero unas veces se pone terco el erp y solo he tenido que descomprimir un openerp nuevo le cambio el nombre al otro y se lo coloco al nuevo… copio los addons viejos en el nuevo con el mismo nombre y listo se arregla… Aunque una vez era que estaba mal configurada la ruta de la funcion para ese reporte y tambien fijate si tienes el RML activo para ese reporte y si prefieres borrar el encabezado que traen las cabeceras por defecto mejor… te dije:
      1 la primera que casi siempre funciona de no funcionar reinstalar wkhtmltopdf
      2 si programaste tu mis la definicion del reporte
      3 si al reporte ay que quitarle algo que no esta funcionando

      Antes de que termine el año voy a crear un manual para hacer nuestro propio Reporte sin descargar nada… saludos espero ayudarte 😀

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s